Jump to content
Yamaha Tenere 700 Forum

ABS ring for Speedo Correction!


Aleksandar13
 Share

Recommended Posts

New batch in stock and going out very fast ... Secure yours now 😁😄... 

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Last batch now gone ... Cutting new rings next week... Grab yours before Christmas 😉😂

Link to comment
Share on other sites

Don't let the Speedo discrepancy make you lose your mind , pm me for orders ... 😁

  • Like 2
Link to comment
Share on other sites

Hi Aleksandar

I need to buy a couple of phonics wheels 42 holes for my t700.

I am from Italy 

How much is the cost for the wheels and the shipment?

thank-you

 

Dario

 

  • Like 1
Link to comment
Share on other sites

10 minutes ago, Dariuz59 said:

Hi Aleksandar

I need to buy a couple of phonics wheels 42 holes for my t700.

I am from Italy 

How much is the cost for the wheels and the shipment?

thank-you

 

Dario

 

Hi Dario,

 

I've sent you a PM. Italy is close to use so shipping is easy.

Aleks

Link to comment
Share on other sites

IM READY @Aleksandar13!  I CANT TAKE IT ANYMORE!!! LOL. My speedo is off consistently by 3-4 (MPH) against my Garmin GPS. On my other bikes/ SXS its either “on” or off by just 1 MPH. 

 

 

  • Haha 1

 

 

Link to comment
Share on other sites

13 minutes ago, DT675 said:

IM READY @Aleksandar13!  I CANT TAKE IT ANYMORE!!! LOL. My speedo is off consistently by 3-4 (MPH) against my Garmin GPS. On my other bikes/ SXS its either “on” or off by just 1 MPH. 

 

 

Send me a pm with details 😃

Link to comment
Share on other sites

I powder coated the new rings mat black and finally got a chance to install them today. The install was very straight forward and everything works great. It sure is nice to have an accurate speedo.

Thanks for making this possible.

  • Like 2
Link to comment
Share on other sites

On 11/1/2021 at 12:18 AM, Toddler said:

I powder coated the new rings mat black and finally got a chance to install them today. The install was very straight forward and everything works great. It sure is nice to have an accurate speedo.

Thanks for making this possible.

No worries, always a pleasure it's a brilliant solution and without hassle.

New rings are going to be cut for end of the week.

Aleks

Link to comment
Share on other sites

On 10/30/2021 at 4:22 PM, DT675 said:

IM READY @Aleksandar13!  I CANT TAKE IT ANYMORE!!! LOL. My speedo is off consistently by 3-4 (MPH) against my Garmin GPS. On my other bikes/ SXS its either “on” or off by just 1 MPH. 

 

 


Mine is off by 7mph 🤪

  • Like 1
  • Haha 1
Link to comment
Share on other sites

34 minutes ago, Burnsey said:


Mine is off by 7mph 🤪

Send me a pm ... We get that sorted 🤩

Link to comment
Share on other sites

New batch cut and will be shipped out later this week for all the orders.

Aleks

IMG20211110064234.jpg

  • Like 1
Link to comment
Share on other sites

All orders have been shipped , another batch has been cut .. secure yours and treat the bike with an accurate Speedo 🤩😃.

 

Link to comment
Share on other sites

New 42 hole ABS rings received this week. Fitted them on Friday morning. The tolerances are just fine, just needed a light tap with the back of a screwdriver for the ring to click into its seat on the hub - that's the difference a coat of paint makes. Very close correspondence with the GPS speed now as expected.

 

Nothing to add to the comments already made by your satisfied customers.  A simple mechanical solution to a problem that should never have been.  A 10% speedo error was 'daein ma heid in!'  (If you're Scottish you'll know what that means. 😀)   

 

Aleksandar13 is the man!

  • Like 1
Link to comment
Share on other sites

On 11/21/2021 at 10:16 AM, Joni said:

New 42 hole ABS rings received this week. Fitted them on Friday morning. The tolerances are just fine, just needed a light tap with the back of a screwdriver for the ring to click into its seat on the hub - that's the difference a coat of paint makes. Very close correspondence with the GPS speed now as expected.

 

Nothing to add to the comments already made by your satisfied customers.  A simple mechanical solution to a problem that should never have been.  A 10% speedo error was 'daein ma heid in!'  (If you're Scottish you'll know what that means. 😀)   

 

Aleksandar13 is the man!

Thanks for the feedback... Really appreciate it. 

 

Aleks

Link to comment
Share on other sites

Paid on the 29th November and still haven’t received the rings despite Aleks having promised to dispatch a week ago. 😐

 

UPDATE: Both rings were received last week and all looking good.

Edited by bicons
Update
Link to comment
Share on other sites

9 hours ago, bicons said:

Paid on the 29th November and still haven’t received the rings despite Aleks having promised to dispatch a week ago. 😐

They have been shipped and came back to me due to incorrect address, fault is mine I will resend tomorrow. 

Aleks

Link to comment
Share on other sites

I received mine (awhile back)- thanks Aleks!  I’m in the process of painting them. I wont be able to see how accurate they are though until spring now. 

 

 

Link to comment
Share on other sites

@DT675how best to paint them? Should have mine in a weeks or so, in California. Anyone leave them raw?

Thx for any input.

Chris

Link to comment
Share on other sites

9 minutes ago, thepointchris said:

@DT675how best to paint them? Should have mine in a weeks or so, in California. Anyone leave them raw?

Thx for any input.

Chris

Can't leave them raw they are mild steel and will rust quickly. Spray paint will do the job.

Aleks

Link to comment
Share on other sites

10 hours ago, thepointchris said:

@DT675how best to paint them? Should have mine in a weeks or so, in California. Anyone leave them raw?

Thx for any input.

Chris

Well I’m no expert in what to do but I can sure tell you what I’ve done. 
 

I put the rings on a cardboard box, sprayed them with etching primer. Let them dry for at least 24 hrs. 
 

Then I sprayed one decent fully covering coat of gloss black.  Let them sit for a few days (so the next step won’t make them bubble)

 

last step I sprayed one fully covering coat of an enamel clear coat. Once again I let them set up for a few days before I flipped them over to do the other sides so they don’t bubble. 
 

I have a few dust particles in them up close but their good enough for me. 

  • Like 2

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Our Friends

Tenere across the USA

Tenere 700 Forum. We are just Tenere 700 owners and fans

Tenere700.net is not affiliated with Yamaha Motor Co and any opinions expressed on this website are solely those of ea individual author and do not represent Yamaha Motor Co or Tenere700.net .

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.